[PATCH 1/2] gdi32/tests: Move out common functions into a separate file named misc.c|h

Zebediah Figura (she/her) zfigura at codeweavers.com
Mon Feb 8 10:26:55 CST 2021


On 2/8/21 6:21 AM, Ralf Habacker wrote:
> Am 08.02.21 um 12:23 schrieb Alexandre Julliard:
>> Ralf Habacker <ralf.habacker at freenet.de> writes:
>>
>>> This is used to avoid code duplication for adding an 'advanced' gdi32 test.
>>
>> That doesn't seem necessary. You can simply add the new test to dib.c.
>>
> Adding the new tests to dib.c with
> 
> START_TEST( advanced )
> {
>      CryptAcquireContextW( &crypt_prov, NULL, NULL, PROV_RSA_FULL,
> CRYPT_VERIFYCONTEXT );
> 
>      test_advanced_graphics();
> 
>      CryptReleaseContext( crypt_prov, 0 );
> }
> 
> at the end does not add the new test 'advanced' to the list of available
> tests.
> 
> $ ~/src/wine-build/dlls/gdi32/tests> wine ./gdi32_test.exe
> Valid test names:
>      bitmap
>      brush
>      clipping
>      dc
>      dib
>      driver
>      font
>      gdiobj
>      generated
>      icm
>      mapping
>      metafile
>      palette
>      path
>      pen
> 
> It looks that it is recommended to place each START_TEST() macro into a
> separate file as it was done with all present tests.
> 
> bitmap.c:5938:START_TEST(bitmap)
> brush.c:364:START_TEST(brush)
> clipping.c:557:START_TEST(clipping)
> dc.c:1675:START_TEST(dc)
> dib.c:3200:START_TEST(dib)
> driver.c:792:START_TEST(driver)
> font.c:7723:START_TEST(font)
> gdiobj.c:365:START_TEST(gdiobj)
> generated.c:13563:START_TEST(generated)
> icm.c:305:START_TEST(icm)
> mapping.c:713:START_TEST(mapping)
> metafile.c:4303:START_TEST(metafile)
> palette.c:328:START_TEST(palette)
> path.c:1922:START_TEST(path)
> pen.c:690:START_TEST(pen)

The point is that it's not worth adding a new test unit; you can just 
run your new tests as part of the "dib" test unit.

> 
> Regards
> Ralf
> 



More information about the wine-devel mailing list