[PATCH 6/6] winegstreamer: Add timestamp and duration to struct wg_sample.

Rémi Bernon rbernon at codeweavers.com
Tue Apr 5 03:35:23 CDT 2022


On 4/5/22 10:30, Rémi Bernon wrote:
> On 4/5/22 01:07, Zebediah Figura wrote:
>> On 4/4/22 16:48, Rémi Bernon wrote:
>>> diff --git a/dlls/winegstreamer/unixlib.h b/dlls/winegstreamer/unixlib.h
>>> index f4e2ea4966b..ca361fe54bb 100644
>>> --- a/dlls/winegstreamer/unixlib.h
>>> +++ b/dlls/winegstreamer/unixlib.h
>>> @@ -114,10 +114,14 @@ struct wg_format
>>>   enum wg_sample_flag
>>>   {
>>>       WG_SAMPLE_FLAG_INCOMPLETE = 1,
>>> +    WG_SAMPLE_FLAG_HAS_TIMESTAMP = 2,
>>> +    WG_SAMPLE_FLAG_HAS_DURATION = 4,
>>>   };
>>>   struct wg_sample
>>>   {
>>> +    /* timestamp and duration are in 100-nanosecond units. */
>>> +    LONGLONG timestamp, duration;
>>>       UINT32 flags;
>>>       UINT32 max_size;
>>>       UINT32 size;
>>
>> I don't want to bikeshed the naming and types, and I'm willing to sign 
>> off on the patch regardless, but is there a reason to diverge from 
>> wg_parser_buffer here?
>>
> 
> Sure,
> 

FWIW I think the reasoning was that it was the only name using an 
acronym, which I also rather try to avoid doing. I don't care very much 
though.

-- 
Rémi Bernon <rbernon at codeweavers.com>



More information about the wine-devel mailing list