[PATCH vkd3d 03/12] vkd3d-shader/hlsl: Introduce hlsl_free_deref().

Giovanni Mascellani gmascellani at codeweavers.com
Tue Jul 5 05:10:35 CDT 2022


Hi,

Il 01/07/22 23:24, Francisco Casas ha scritto:
> +void hlsl_free_deref(struct hlsl_deref *deref)
> +{
> +    hlsl_src_remove(&deref->offset);
> +}
> +

Again, mostly a nitpick, but personally when a function is called "free" 
and receives a pointer, I assume that it will free the pointer itself 
(after perhaps doing cleanup). Here there is the cleanup, but the 
pointer is not freed, so I would rename to "hlsl_unlink_deref", for 
example. Not sure if others agree with my sentiment.

Giovanni.



More information about the wine-devel mailing list