[PATCH 0/1] MR306: reg: Add REG_QWORD support to 'add'.

Hugh McMaster (@hmc) wine at gitlab.winehq.org
Fri Jun 24 07:46:46 CDT 2022


Hugh McMaster (@hmc) commented about programs/reg/add.c:
>              *(DWORD *)*data_bytes = val;
>              break;
>          }
> +        case REG_QWORD:
> +        {
> +            LPWSTR rest;
> +            UINT64 val;
I'd really prefer `WCHAR *` for new code. You can also just use `QWORD` for `UINT64`, although the latter is probably more readable at a glance.

-- 
https://gitlab.winehq.org/wine/wine/-/merge_requests/306#note_2644



More information about the wine-devel mailing list