[PATCH 0/2] MR308: Add "wine/str.h", use "wine/heap.h" and it in winemenubuilder

Davide Beatrici (@davidebeatrici) wine at gitlab.winehq.org
Fri Jun 24 13:00:46 CDT 2022

The complexity reduction would be in their usage, not the implementation itself.

As I mentioned in the commit's message, there are already several wrappers for functions such as `WideCharToMultiByte()` and `MultiByteToWideChar()` across the codebase.

If you're referring to `utf8len()`, `utf8size()`, `utf16len()` and `utf16size()`: I can see why they're confusing. We could match the standard naming convention by removing `utf8len()` (which is not used anyway) and renaming:

- `utf8size()` -> `strsize()`.
- `utf16size()` -> `wstrsize()`.
- `utf16len()` -> `wstrlen()`.

What do you think?


More information about the wine-devel mailing list