portability fixes (yet another attempt)

Steven Edwards steven_ed4153 at yahoo.com
Wed Feb 16 22:05:33 CST 2005

Hi Thomas,

--- Thomas Weidenmueller <wine-patches at reactsoft.com> wrote:
> I unfortunately don't know as I couldn't find referencces to the other 
> HAVE_* definitions, which I guess are somewhere outside of wine sources. 
> There however needs to be a macro for strtoulW which can be named 
> differently... .e.g. HAVE__VSNPRINTF is also just undef'ed, I'm sorry I 
> don't know if that's defined in some gcc headers (mingw at least doesn't 
> define them), libc or somewhere else.

You need to add a check to the configure and configure.ac scripts for these functions. When you
run ./configure it will check to see if this function is implemented on the given platform and
define as needed.


Do you Yahoo!? 
Take Yahoo! Mail with you! Get it on your mobile phone. 

More information about the wine-patches mailing list