dplayx: Enclose NS_GetOtherMagic() in #if 0 since it's only used from code enclosed in #if 0.

Francois Gouget fgouget at free.fr
Wed May 13 03:38:08 CDT 2009


---

There's three other options:
 1) Remove this dead code altogether...
 2) Replace the #if 0 with an if (0) so that the function is 'used'
 3) Fix the code so it has neither #if 0 nor if (0) (which might be the 
    same as option 1, I have no idea)


 dlls/dplayx/name_server.c |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/dlls/dplayx/name_server.c b/dlls/dplayx/name_server.c
index e6a6b62..a503270 100644
--- a/dlls/dplayx/name_server.c
+++ b/dlls/dplayx/name_server.c
@@ -183,6 +183,7 @@ DWORD NS_GetNsMagic( LPVOID lpNSInfo )
   return lpHdrInfo[1];
 }
 
+#if 0
 /* Get the magic number associated with the non NS end */
 DWORD NS_GetOtherMagic( LPVOID lpNSInfo )
 {
@@ -190,6 +191,7 @@ DWORD NS_GetOtherMagic( LPVOID lpNSInfo )
 
   return ((LPDWORD)lpCache->lpLocalAddrHdr)[1];
 }
+#endif
 
 void NS_SetLocalAddr( LPVOID lpNSInfo, LPCVOID lpHdr, DWORD dwHdrSize )
 {
-- 
1.6.2.1




More information about the wine-patches mailing list