[PATCH 2/2] mmdevapi: Add pulseaudio on ignore for older openal-soft's

Maarten Lankhorst m.b.lankhorst at gmail.com
Wed Apr 14 14:24:56 CDT 2010

I cannot query the version string unless a device context is created. 
Since OpenAL-1.12 added support for thread local contexts I use that to 
determine whether pulseaudio should be ignored or not. OpenAL 1.10 and 
older will crash on pulseaudio. Since other os's don't support 
pulseaudio it is safe.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: 0016-mmdevapi-Add-pulseaudio-to-ignore-list-on-older-openal.txt
URL: <http://www.winehq.org/pipermail/wine-patches/attachments/20100414/fbec4c1a/attachment.txt>

More information about the wine-patches mailing list