No implementation for shlwapi.dll

cacook at cacook at
Sun Apr 29 08:56:32 CDT 2001

Tried every permutation of shell, shell32 & shlwapi.  It is clear that shell & shell32 must come from a common source, but nevertheless always got the same error message, with one exception:
When I loaded all 3 builtin, it complained instead that shfolder has a problem.

Running RedHat 7.1|Helix|Nautilus, with Win98r1 .dlls.

The best way out is always through.
      - Robert Frost  A Servant to Servants, 1914


Invoking /opt/wine/bin/wine.bin cc32d475.exe ...
err:win32:fixup_imports No implementation for shlwapi.dll.0(StrRetToBufA) imported from shell32.dll, setting to 0xdeadbeef
err:win32:fixup_imports No implementation for shlwapi.dll.0(StrRetToBufW) imported from shell32.dll, setting to 0xdeadbeef
Wine exited with a successful status

Andreas Mohr wrote:

> [ouch, HTML mail :-(]
> On Fri, Apr 27, 2001 at 04:28:45PM -0600, quantum7 at wrote:
> Well, some versions of Windows split StrRetToBuf*() differently among
> shell32.dll and shlwapi.dll.
> Try different native and/or builtin combinations of shlwapi and shell32,
> e.g. --dll shlwapi,shell32=b or so.
> Hmm, yes, this should be added to the troubleshooting stuff...
> --
> Andreas Mohr                        Stauferstr. 6, D-71272 Renningen, Germany
> Tel. +49 7159 800604     

More information about the wine-users mailing list