RH7.1 and wine won't read windows' .reg files

lost wmudgenospam at tpg.com.au
Fri Aug 3 04:32:14 CDT 2001


I've tried and tried to get wine working. It will run notepad.exe etc. but
nothing tricky. I have a windows partition, and have read many howto's etc.
but I'm not getting very far.

Whenever I try and run anything tricky (M$Money or Outlook, and I do realise
that the support for these apps may be shakey) I get error message from the
program along the lines of "Failed to load a required Money component.
Please re-install from orig. disks". Seemed to me like my windows .reg files
weren't being read. Same error with Outlook.

I checked and rechecked the wine config file, and it said it was trying to
load windows registries. I was using an .rpm version so I downloaded and
compiled the source (as most doco's I read said to use the wine install tool
which isn't included in the binary .rpm.

Problem is, and yes I used the wine install script or whatever it's called,
the compilation trashed my whole system. The compile went for >30mins, it
doesn't even take that long to compile a new kernel. When I rebooted, my
system wouldn't load modules, I got kernel errors, system hangs, you name
it. However, despite a message at the final compilation stage saying it
errored while reading my windows .reg files, the reg files copied to my
.wine directory were from my windows install. (Well when you search them
they have outlook and money entries and before they didn't.)

I installed my system again from scratch and re-installed the wine .rpm,
copied the "correct" .reg files from the last wine install (involved using
rescue mode from the install cd as I couldn't even mount my windows
partition to back it up after the wine install gone wrong) but I still get
the same errors.

As you can see I'm pretty keen to get the thing working, I can even forgive
it trashing my system, but I'm at a loss as to what to try next. Any


More information about the wine-users mailing list