Diablo 2 with Battle.net - another step closer again

Robert Laverick csujo at scabserver.com
Sat Aug 11 18:27:34 CDT 2001

Well that seems not to be the problem with battle.net, not that I've fixed it 
but that I've found something else that's what's causeing the problem...
thanks to the ability to sroll the display away from the aplicaion (never 
though I Thank that for anything!) I was able to see what's going on when it 
trys to connect to battle.net.  when I try to connect I get 2 fixmes very 
close together, I assume it's the program allowing 1 retry...

fixme:advapi:CryptAcquireContextA (0x4605440c, Blizzard_Storm, Microsoft Base 
Cryptographic Provider v1.0, 1, 00000000): stub!
fixme:advapi:CryptAcquireContextA (0x4605440c, Blizzard_Storm, Microsoft Base 
Cryptographic Provider v1.0, 1, 00000008): stub!

but like all my thoughts it could be complet rubish I'm just about to dive in 
and have alook, I'll post again when I get something alittle more concreet!
from the look of the name this isn't going to be good, I'll bet there's 
nowhere that this CryptAcquireContextA is properly documented and that it's 
all closed box, but somethimes I'm worng (more often than not it seems when 
thinking about wine <G> guess I'll get it eventualy)
Thoughts, comments? any crypto experts in the house?
I'll be back

On Saturday 11 August 2001 18:24, you wrote:
> Yes I've done this and I get the sinle player working fine, but when
> logging into battle.net it can't validate the game. I have yet to try in
> windows to see if this is that same, running Dload.exe it validates fine,
> but I suspect that the crack is mostly a wraper that intercepts the check
> and sorts it out. When I run the game_crk.exe I don't get the problem of
> failing at the start but it dosn't play online, so I think the two files
> work like this.  game_crk is a version of game.exe without the CD copy
> protection stuff, and DLoad.exe is a wrapper that allows the version
> checking to take place.  when I try and run DLoad this is what happens....
> a box titled Error comes up, stating "Cant execute game_crk.exe in current
> Dir." with only an ok button, and the terminal screen show 3 fixme's :
> fixme:ntdll:NtOpenProcessToken (0xffffffff,0x00000028,0x40606918): stub
> fixme:advapi:LookupPrivilegeValueW ((null),L"SeDebugPrivilege",0x66f01824):
> stub
> fixme:ntdll:NtAdjustPrivilegesToken
> (0x0000cafe,0x00000000,0x66f01820,0x00000000,(nil),(nil)),stub!
> which I assume is thie DLoad trying to load the game_crk.exe and failing.
> can anyone help e with this, I'm willing to get into code, but am a java
> programmer and haven't the first clue of where to start, my knowledge of
> Windows progamming is even worse than my knowledge of c (I've done quite a
> bit of C in BSPlibC, a lang uisng C to optimaly program parallel
> computers). I'll even live with someone surgesting a really dirty hack to
> get it running, even if I have to do it to my own copy of wine.... I've got
> a few installed to keep a running one seperate from the one I'm messing
> with.
> anyway it's over to the audience again, can anyone help?  or surgest
> another crack that will work, or even a way to fix this one.
> Cheers.
> Rob
> On Friday 10 August 2001 17:41, you wrote:
> > What command did you use to run WINE? I use "wine game_crk.exe" and it
> > works. I seem to recall getting that error message before I managed to
> > get it to work, and IIRC it was when I used "wine dload
> > ". I haven't tried battle.net, but it looks like the same crack so it
> > should work (?).
> >
> > _______________________________________________
> > wine-users mailing list
> > wine-users at winehq.com
> > http://www.winehq.com/mailman/listinfo/wine-users
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.com
> http://www.winehq.com/mailman/listinfo/wine-users

More information about the wine-users mailing list