wine's winhelp doesn't compile

gerard patel g.patel at
Sat Dec 1 18:30:18 CST 2001

On Sat, 01 Dec 2001 22:43:37 GMT, James Juran
<jamesjuran at> wrote:

>I think this may be a glibc issue, rather than a compiler issue.  I get
>the same error as Sylvain.  I'm using a Red Hat 7.2 machine.  The exact
>same error occurs with Red Hat's gcc-2.96-98 and gcc3-3.0.1-3.
>Gerard, what is the prototype for gethostname in /usr/include/unistd.h
>for gethostname?

>james[1]%rpm -qf /usr/include/unistd.h


>james[2]%grep gethostname /usr/include/unistd.h
>extern int gethostname (char *__name, size_t __len) __THROW;

extern int gethostname (char *__name, socklen_t __len) __THROW;

./include/bits/types.h:typedef unsigned int __socklen_t; 

>   Called just like `gethostname' and `sethostname'.
>james[3]%grep gethostname ../../include/winsock.h
>int WINAPI WS(gethostname)(char*,int);

int WINAPI WS(gethostname)(char*,int); 

>james[4]%rpm -q gcc


>james[5]%rpm -q gcc3


>james[6]%gcc -v
>Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
>gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)

Reading specs from /usr/lib/gcc-lib/i586-mandrake-linux/2.96/specs
gcc version 2.96 20000731 (Linux-Mandrake 8.0 2.96-0.48mdk)


More information about the wine-users mailing list