wine problem - cannot write to directory

lawson_whitney at lawson_whitney at
Tue Jul 31 20:49:34 CDT 2001

On Sat, 28 Jul 2001, ZalekBloom at wrote:

> I just installed a new version of wine and wine stopped working.
> It starts and I am getting a message that I have no permition to write on
> my Win c:\ disk.
> I checked that root is owner of c:\ directories, so I switched to root
> user (even my userid is defined in the same group as root) and I am
> gettin a message that root cannot run wine.
> So I tried to "chmod 774 Agent" (Agent is directory of Agent program I
> tried to run), but "ls -al" showed that c:\Agent directory permitions
> were not changed (stayed rwxr-xr-x).
> Any idea how to solve this problem?
> Thanks,
> Zalek

I hate to say it, but read the fine
doco.  <wine>/documentation/installing.sgml, the section on dealing with
fat/vfat partitions.

feel free to use this nasty little sed program on the sgml, or get
another format from the wine ftp sites (see <wine>/ANNOUNCE).

sed -e 's/<[^<>]*>//g' -e 's/&lt;/</g' -e 's/&gt;/>/g' $1 |less -ni

chmod 774 Agent _can't_ do anything.  a fat fs has no structure to
record permissions in, so permissions and ownership for the whole fs are
set by mount.  Have root umount your windows directory and fix
/etc/fstab so the user who runs wine can mount it, or owns it no matter
who mounts it, or do a recursive read of man mount, man fstab, and
man 2 umask until you understand how *nix handles vfat filesystems,
or just read the wine doco I mentioned.


Juno offers FREE or PREMIUM Internet access for less!
Join Juno today!  For your FREE software, visit:

More information about the wine-users mailing list