gerard patel g.patel at
Wed Jul 4 15:27:07 CDT 2001

On 4 Jul 2001 13:22:01 -0400, bpostow at (Brian Postow) wrote:

>er, that was supposed to be win2000...
>Now, here's the odd thing, on the suggestion of someone who is (I
>believe) off group, I tried nt40 on a CVS RPM install. it claims that
>not only does it have directX, but 3D as well. However, after testing
>3dfx Glide (which I'm pretty sure should be included right?) it tells
>me that I need to install the latest nt4 service pack. 
>All other winvers fail when testing hardware and says I need directX.

So the software you use is using very advanced detection of
installed software : if the OS version is win2K, it 'knows'
that it comes with directX. If not, it (probably) tests the registry
(unless it searches directly for a file). If you don't have
the needed registry entries from the defaut Wine registry
file, you should try to use debugmsg +file,+dosfs,+reg to
find what the app is trying to check.

>I even tried installing the directX 7.1 that came with Diablo, and
>(unsurprisingly) it didn't help. 

Err, I'm sure that Wine doc says somewhere that 'native'
DirectX libraries can not work.


More information about the wine-users mailing list