Codeweavers install problem.

William D. Tallman wtallman at
Tue Jul 10 20:31:39 CDT 2001

Hi...  trying to install Codeweavers-wine-20010305, which is the latest 
stable build I understand.

It configures and then informs me that it'll compile but that building 
without the Xpm development files won't work.  Sure enough...  they were 

So I go get the latest Xpm stuff and they turn out to be libxpm4-3.4 and 
libxpm4-devel-3.4.  Got them in .src.rpm and built and installed them 
without a hitch.  Reconfigured the wine source and it still couldn't find 
the files.

There seemed to be some indication that it was actually looking for a 
version that has been obsoleted, but the header file it was calling for is 
on the system.

As near as I can tell, it wants to find XpmCreatePixmapFromData, which is 
listed as one of a number of functions defined in the  
/usr/X11R6/include/X11/xpm.h header file, and so far as I can tell that's 
in one of the shared libraries in, which as a synlink  The shared library is a binary, and a hexdump shows the 
function is part of that library.

What do I need to do so that the configuration routine finds Xpm (without 
which wine won't work but they'd happily compile without it....arrgghh!!)? 
 I looked at the various switches and args but no joy.

Has anyone run across this, and if so, anyone got an answer?

Thanks in advance, and if this was posted recently, my apologies but I 
read everything on the news server....

Bill Tallman
Registered Linux User: #221586
Mandrake 7.2 and IceWM:  
What *was* that other OS...

More information about the wine-users mailing list