How to get Civ 3 running...

Malte Cornils malte at
Thu Nov 29 19:24:38 CST 2001

Tom Morton wrote:
> no luck. It installed fine, but won't run. With recent CVS winex i get:
> fixme:win32:DEVICE_Open Unknown/unsupported VxD SICE. Try --winver nt40 or win31 !
> fixme:win32:DEVICE_Open Unknown/unsupported VxD SIWVID. Try --winver nt40 or win31 !
> It doesn't work with --winver nt40 either.

Huh? At least the VxD fixmes should be gone then...

> And with the debian "wine_0.0.20011108-2_i386.deb" build i get:
> [~/.wine/c_drive/civ3]$ wine Civilization3.exe
> fixme:module:CreateProcessA (E:\~ef7194.tmp,...): CREATE_NEW_CONSOLE ignored
> fixme:module:CreateProcessA (E:\~ef7194.tmp,...): NORMAL_PRIORITY_CLASS ignored
> FIXME:pthread_rwlock_rdlock
> FIXME:pthread_rwlock_unlock
> FIXME:pthread_rwlock_rdlock
> FIXME:pthread_rwlock_unlock

This looks more like what you would also get with winex;

> Then a message box pops up titled "A debugger has been detected", stating
> "Unload the debugger and try again". And it quits.

However, this is IIRC a symptom of the copy protection (SafeDisc or
SecuROM, not sure) at work. The latest transgaming binaries
(available to subscribers) support this; however, the source does
not contain this work (yet??) probably due to license issues. 

So, the advice is: try the .deb binaries from if you
can, or get a crack to remove the protection (though I do not know
if it is legal in your country (DMCA?)).

Also, you might try voting for "Civ 3" support in the transgaming
polls. The poll only runs until... today (30th November, 2001), so
in order to influence it, you should subscribe rather soon :-)

Yours Malte #8-)

More information about the wine-users mailing list