Problem with Xilinx 4.1.01i tools

B. Joshua Rosen bjrosen at
Tue Oct 2 23:18:14 CDT 2001

I've been running earlier revs of the Xilinx tools on ext2 file systems
for a couple of years without any problems.I'll try it on a FAT32
partition and see if that makes a difference.


In <3BBA550E.7000800 at>, Duane Clark wrote:

> B. Joshua Rosen wrote:
>> I'm having a problem with the latest version of the Xilinx tools
>> (Release 4.1.01i). I'm getting the following error from map
>> FIXME:pthread_rwlock_rdlock
>> FIXME:pthread_rwlock_unlock
>> FATAL_ERROR:MapHelpers:mhcsymlib.c:779:1.7 - Problem in parsing the XML
>> file
>>    "/home/bjrosen/win/Xilinx/virtex2/data/SymbolLib.xml":  An exception
>>    occured! Type:RuntimeException, Message:The primary document entity
>>    could not be opened.
>>    Id=F:\clients\sky\skybridge\isky_test_xilinx\\home\bjrosen\win\Xilinx\virtex2
>>    \data\SymbolLib.xml.  Process will terminate.  To resolve this
>>    error, please consult the Answers Database and other online
>>    resources at
>> I was able to run the tools on the same design under Win4Lin so I don't
>> think that this is a Xilinx problem. Does anyone have any ideas about
>> what might be causeing this.
> On previous versions of the Xilinx tools, did you have the data files
> installed on an ext2 filesystem? I have noticed that some of the Xilinx
> tools (I have seen it on ngdbuild) cannot read files on ext2 filesystems
> unless they use 8.3 filenames. In the case of ngdbuild, the error
> message says that the file cannot be found, although it does exist. When
> reading files on win filesystems, the Xilinx tools read all files just
> fine, regardless of the filename length.

More information about the wine-users mailing list