/proc/sys/fs/binfmt_misc/register: no such file or directory

Alukard Vrykolakas nobody at myemail.com
Sun Oct 21 14:50:18 CDT 2001

I get this during booting?  Anyone have any ideas?
I'm running redhat 7.1 w/ kernel 2.4.9-6 and the wine version from the
powertools cd.
Latest version of wine does it also.
I get this error when installing from redhat powertools too:

"execution of %post scriplet from wine 20010131-3 failed, exit status1"

but it installs and seems to work... just my windows service doesn't start.

I have the /pro/sys/fs/binfmt_misc directory but after reading some search
engine results on my probem I don't seem to have the "register" and "status"
files that are supposed to be in there untill I run (something I found
somewhere else):

mount -t binfmt_misc none /proc/sys/fs/binfmt_misc

which seems to get the directory working and then I run

service windows start

and it doesn't complain anymore.

Am I missing something somewhere?  I have a feeling a prerequisite to
installing Wine isn't working quite right and the problem is at a lower

Thanks for any ideas in advance!

More information about the wine-users mailing list