winsock 16 BIT

David Barrena david at
Wed Feb 27 06:13:16 CST 2002


In October I worked with a client-server (using winsock.dll) 16 bit
emulated in wine (Not using ODBC), it worked fine. This aplication needs
to connect to a
server using port ctsql 5557/tcp, this service is in my /etc/services.
And wine made all realy fine (Version 20011108). With the release
20011226 (I think)started the problem. Something changed with winsock

I've upgraded my system , I use Debian Woody ( to wine version
20020122); now the aplication doesn´t work, it can´t connect to the
server. I make a netstat, and the aplictation tryes to connect to 512
(exec) port and not to 5557 who I need. I change all services but the
aplication always goes to 512 exec tcp port. What could be the problem?.

I think wine read /etc/services but not send the correct port number
(using always 512) to winsock.dll, or winsock.dll doesn´t works fine.

P.D.  Working with the same Server and Port (5557/tcp) with 32bits
aplications work fine and fast.
P.D.  Thanks to Carol Farlow for her first anwser.

More information about the wine-users mailing list