Problems with CritSec and Wine 20020605 !?

Christian Neumair christian-neumair at
Sun Jul 7 12:39:43 CDT 2002

> When I run "wine Orion95.exe" on the command line, a black rectangle 
> appears in the upper left corner of the screen.
> Then I get the following messages:
> fixme:ddraw:Main_DirectDraw_SetCooperativeLevel 
> (0x403ab808)->(00010021,00000011)
> fixme:x11drv:X11DRV_DDHAL_CreatePalette stub
> fixme:dsound:IDirectSoundImpl_SetCooperativeLevel 
> (0x403b0db8,00010021,2):stub
> err:ntdll:RtlpWaitForCriticalSection section 0x403b1140 "?" wait timed 
> out, retrying (60 sec) tid=08089f08
> wine: Unhandled exception, starting debugger...
> fixme:console:SetConsoleCtrlHandler (0x404bfa80,1) - no error checking 
> or testing yet
> err:dplay:DirectPlayEnumerateA : no service providers?

Have you already tried starting the same program with winex (a
wine-distribution providing much better DirectX capabilities)?
I'm sure winex is included in SuSE as package but as i'm not using this
distro i can't verify this.
Just try running "winex" to see whether it's installed or not.
Goot luck!

see you,

More information about the wine-users mailing list