I can't make serial or parallel ports work

Romek Krisztian r-krisztian at softhome.net
Sun Jun 23 06:34:39 CDT 2002


> I have configured it in the wine's config file as documented but the
> applications can't access any serial or parallel port what can be wrong?
> My config file is attached to this message.

I have the same problem. I've read a lot of manuals and can't get serial 
ports to work. I've experienced that a lot of people asked that and noone got 
a solution. Me too... :((( I've also asked irc.openprojects.net #winehq and 
nobody could help me.

Somebody said that if I use a later version like 200011xx or dunnowhat then 
it should work because serial ports algorythm was changed in wine.

I have a message which told me to use this lines in my conf:

"read" = "0x779,0x379,0x280-0x2a0,0x278-0x27f,0x378-0x37f"
"write" = "0x779,0x379,0x280-0x2a0,0x278-0x27f,0x378-0x37f"

So paralell ports should work... have a try, but serial ports still doesn't 

I don't know something. I've asked my bios what does it say about ports:

COM1: 3F8h
COM2: 2F8h
Parallel: 378h

I've tried that with this config:

"read" = "0x3f8,0x2f8,0x280-0x2a0,0x278-0x27f,0x378-0x37f"
"write" = "0x3f8,0x2f8,0x280-0x2a0,0x278-0x27f,0x378-0x37f"

But didn't work. 

Any ideas?

Romek Krisztian
r-krisztian at softhome.net

More information about the wine-users mailing list