Having trouble getting winedbg to be invoked, trying to run sol.exe

Jonadab the Unsightly One jonadab at bright.net
Tue Mar 5 11:37:58 CST 2002

Well, I retitled this message several times while writing it, as I
discovered more things; the brick wall I ultimately ran into is
getting the debugger to work.  So, bear with me...

I'm trying to get Wine working.  Ultimately I have a couple of apps I
want to get working, but at the moment I'm trying to run sol.exe to
verify that Wine is installed and configured properly and... having

Here was my original commandline:
wine --winver win95 --managed C:\\windows\\sol.exe

Same thing happens without --managed.  Either way, I get a couple of
pthread fixme messages and it tells me it couldn't stat the floppy
drive, and then I get this dialog:

 Exception raised
      Unhandled page fault on write access to
  X   0x0855c2b8 at address 0x4010f576.
      Do you wish to debug it ?
      [Yes]    [No]
When I click yes, Wine can't start the debugger.  It says to read the
Wine developer's guide for information on starting the debugger, but I
read the whole section on debugging and cannot find how to get it
working.  If I use winedbg on the command line instead of just wine,
everything happens just the same as when I use wine, right up to the
message that Wine can't start the debugger.  The developer's guide
also suggests wine -debug, but if I try that (or --debug) wine gives
me a list of valid commandline options.  It says that the path to the
debugger must be available on a DOS drive, but I already set up a
drive for /usr/bin (which is what which winedbg tells me) to solve an
earlier complaint about winereal not being reachable on a DOS drive.
There's a reference to a Wine registry key, but no clue as to where to
put it.  It says wineinstall sets it up, but which wineinstall reports
nothing.  I presume the Wine registry is separate from the Windoze
registry?  Saaaayyyy....  wine.conf looks a LOT like a REG file...
but it says in a comment that all keys are relative to
whereas the key that the developer's guide seems to indicate I should 
set is outside that tree,
in \\Machine\\Software\\Microsoft\\Windows NT\\Current Version\\AeDebug
Is that right even though I don't have NT?  Is there something special
I can do in wine.conf to set the key so that winedbg will be invoked?
Can I just boot Windows and set the key with regedit?

This is probably the first thing I need help with, is getting the
debugger to work so that I can post more useful inquiries.  

Anyway, I also get this:
err:ntdll:RtlpWaitForCriticalSection Critical section 0x4011b04c wait timed out, retrying (60 sec) fs=008f
err:ntdll:RtlpWaitForCriticalSection Critical section 0x40119610 wait timed out, retrying (60 sec) fs=008f
err:seh:EXC_DefaultHandling Unhandled exception code c0000194 flags 0 addr 0x400f8b70

I found some references to the Rtlp error in some web-based mailing
list archives, but Dave Hawkes seems to indicate (about January this
year) that large applications are particularly prone to this error.
Solitaire is generally not considered large, as apps go.  

I also did a Google Groups search and turned up an older thread from
January 2001 that indicates a mismatch between native and builtin
DLLs.  Someone signing as "Walt" suggests using nothing native except
msvcrt, and Jon Griffiths says crtdll should go with that for

So, I followed Walt's --debugmsg +loaddll suggestion, and get this:
krnl386.exe                       builtin
system                            builtin
wprocs                            builtin
C:\windows\system\advapi32.dll    builtin
GDI.EXE                           builtin
x11drv.dll                        builtin
display                           builtin
msvcrt20.dll                      native
rpcrt4.dll                        native
ole32.dll                         native
shlwapi.dll                       builtin
comctl32.dll                      builtin

I messed with wine.conf and made ole32 builtin, same result.  Changed
over rpcrt4 also, and for a moment I thought I had solved the problem:
a window popped up, green background, ugly playing cards...  but the
moment I click on a card, bad things happen.  If I don't click a card,
I can do anything else:  reposition the window, use the menus, change
the options and card face design, all that stuff, but when I click on
a card, I get an Exception Raised dialog saying "Unhandled page fault
on read access to 0x00000001 at address 0x00000001.  Do you wish to
debug it?  At this point, clicking either yes or no freezes the
Solitaire window solid; I can no longer even reposition the window or
anything, and it stays in front of whatever window I switch to.  I got
rid of it by pulling up the terminal window and Ctrl-C.  (If I clicked
yes, I also got the message about not being able to start the
Mandrake 8.1, Wine release 20010731.  Multiboot system with Windows 95
OSR2 on another partition (and DOS 6 on another and RH6 on another and
Windows Me on another and PowerBoot on the MBR and ...  nevermind)

I _think_ I have my drives and stuff set up correctly in wine.conf,
but if that could be the problem, I'd be happy to strip out the
comments and post it here.


  1.  How do I get winedbg to be invoked?
  2.  Anybody have previous experience with this problem with sol.exe?
For kicks, I tried calc.exe, and after making the same DLL adjustments
as for sol.exe above I was able to get that to mostly work, although
the position of some of the buttons was clearly off so that some
things overlapped.  But I was able to do some calculations with it
without crashing.  So my Wine installation isn't _totally_ broken.
Not sure what's wrong with Solitaire, but I hesitate to try something
large like MS Works 4 (much less Pegasus Mail 4) until I get the
debugger working and figure out why sol.exe has problems...

More information about the wine-users mailing list