United Devices

Frank Reich HoshiFR at gmx.net
Tue Mar 5 17:26:47 CST 2002

Hello everybody.

James S. McGookey wrote:

> I've had problems getting it to run also. Could you please share your findings
> so others can learn as well?

No problem. Just had to find the time for it.

What have I done?

1  Get the most recent (newest) version of WinE. (Could be possible that 
the newest version isn't available as RPM-file but that doesn't matter. 
I didn't take an RPM-file I used the newest TAR.GZ-file I found.)

2  Make sure no other (older) version of WinE is already installed on 
your system - maybe from installing the distribution. If that's the 
case, deinstall it. Any warnings kind of "some files may be needed 
somewhere else..." should be ignored. It doesn't matter because you will 
install the same (but newer) files a little later.

3  Now the README-file included in the new WinE-file should be read. I 
don't know if there's a README with the RPM-file, but in the TAR.GZ-file 
there's one and there it's important to have one.

4  In the README there is somewhere recommended how to install WinE - by 
the command "./tools/wineinstall". This routine should be run.

5  At the end of the installing-process you are asked to configure WinE 
- to tell it where the faked Windows-directory should be and so on. 
After that WinE should work. But it may still be nessessary to configure 
the /home/.wine/config -file by hand. Should also not be the problem 
because in that config-file is written how to enter the paths to the 
faked directories and so on.

6  Now, try to run the Windows-game Solitaire. Copy the sol.exe into a 
directory and run "wine sol.exe" there - from a X-terminal. Should work. 
If it's not working then (very) probably something wasn't correctly 
configured in step 5. Go back and make it better.

7  Try to install the installer of United Devices by the command "wine 
ud_intel_cancer_research" - in an X-terminal.

8  On my system it didn't work. The installer wanted some MSI-files 
which could be donwloaded from a given location. I downloaded the 
InstMsiA.exe and tried to install it but it didn't work, too. But it has 
decompressed itself to the directory c/windows/Installer/InstMsi0. Don't 
be confused because that's the faked Windows-directory on my 
Linux-system. In that directory I found some DLL-files and some other 
files. I copied them all to the directory c/windows/system.

9  Now the United Devices installation worked perfectly. Just like on a 
normal Windows.

10  At the end of it a windows appears for the "first login". For now 
that thing should be closed. You first have to make sure that you have 
the right to write into the installed UD-directory. The root can do 
already but your system should be used only by a user - the root is only 
for administration! Try to copy a simple file into the directory - this 
should work!

11  Now the UD-Agent can be run by the command "wine UD.exe". For this 
change into the installed UD-directory of course. On my system it still 
didn't want to but the second attempt was successful. When the UD-Agent 
downloads a package from the UD-server and begins to compute you was 

Well, that's all for the installation. More to mention I don't remember. 
Any questions? Ask me.

Important to know: The UD-Agent doesn't run perfectly. Just let it 
compute all alone - that's the best you can do.
But I know sometimes one wants to see how's it going. Then you should be 
aware of some failure-messages that can appear. They are mostly 
harmless. The UD-Agent goes on computing.

If I want to see the UD-Agent-window I have to right-click on the little 
bar named "Wine-Systray" - under Windows the UD-Agent also runs in the 
Systray - and choose "Open". Sometimes I can only see the first page and 
cannot access the others. You shouldn't try to access all pages of the 
UD-Agent because e.g. the third one makes a failure. Anyway the 
important windows are the first two.
When I cannot access the second one I go to the X-terminal where the 
process was called and press STRG+C. The process of WinE and so the 
UD-Agent are stopped. Right now you can call "wine UD.exe" once again 
and the UD-Agent is restartet and works fine again.

Sometimes (when the second page is shown) some failure-messages appear. 
By clicking on the "OK"-button they disappear again and the UD-Agent 
works absolutely fine. Those failure-messages only have influence on the 
grafical output - the grafics aren't redrawn - but the computation of 
the UD-Agent is not in danger.

That's all I can say. I hope this works on other systems, too.

Good luck anyway.


More information about the wine-users mailing list