ExitThread won't.

Geoffrey Hausheer rlvuq001 at sneakemail.com
Fri Mar 22 02:21:21 CST 2002

> -----Original Message-----
> From: Ove Kaaven <ovehk at ping.uio.no>
> Hmm. Does the wineserver ever ptrace-attach to the thread?
> (maybe try --debugmsg +server)
I think so:
0868d630: new_thread() = 0 { tid=0x86a56f8, handle=84 }
086a56f8: *fd* 19 <- 23
086a56f8: *fd* 21 <- 24
086a56f8: init_thread( unix_pid=29275, teb=0x41457000, entry=0x421d00, reply_fd=19, wait_fd=21 )
086a56f8: *attached*
086a56f8: *signal* signal=19
086a56f8:Exiting thread...(29275)
086a56f8: *exited* status=0
(that last message is my debug message, pid 29275, which is 

One thing I noticed in the +relay trace was:
08846660:Call kernel32.GetLastError() ret=00424b08
08846660:Ret  kernel32.GetLastError() retval=00000005 ret=00424b08
(in this case 8846660 is the unkillable thread)
But I don't see anything that sets the error.
In case you are wondering, Error 5 is: ERROR_ACCESS_DENIED

There doesn't appear to be anything else interesting (to me)
in the relay trace though.

> Have you tried to kill the processes with -CONT to see if that helps them
> go away after you've tried the other termination signals?

This didn't work.

Any other avenues I can explore?



Protect yourself from spam, use http://sneakemail.com

More information about the wine-users mailing list