running starcraft

Enrico Horn 520007368975-0001 at
Sun Mar 24 16:59:35 CST 2002

On Saturday 23 March 2002 21:52, joey tsai wrote:
> I've just installed the Wine package on my Debian machine, and I'm
> trying to run Starcraft.  The relevant error message I get consistently
> is:
> fixme:dsound:IDirectSoundImpl_SetCooperativeLevel
> (0x406806ec,00010021,2):stub err:ntdll:RtlpWaitForCriticalSection section
> 0x40680a74 "?" wait timed out, retrying (60 sec) fs=037f
> The window (or desktop, I've tried both) for the Starcraft window appears,
> but is blank.  I hear the sound "click" to initialize or whatever.
> I've tried running with many different combination of options like using
> a desktop and enabling dga, all with the same result.  I've also checked
> that my permissions are correct, and I'll get the same message running
> as root.
> Can anybody help me?  I would really appreciate it.  Also, please CC to
> me, I'm not subscribed to this list.
>     // joey tsai
I get the same errors when running a directsound app in wine with the oss 
If you can use the cvs wine with the arts drivers or disable sound in wine 
Btw what sound are you using and what oss drivers?

farmboy1 at

More information about the wine-users mailing list