Kazaa lite and mandrake 9

Rick Romero rick at valeoinc.com
Fri Nov 22 10:19:35 CST 2002

On Fri, 2002-11-22 at 10:16, John Allman wrote:
> >
> >Kazaa... Yea I use 1.7.2 lite on CX-Office
> >To use Kazaa you have to have IE installed and for IE
> >you have to have DCOM
> >I have not tried 2.0 yet .. 1.7.2 is working so why try to fix
> >something that is not broke ..
> >Here is a url : 
> >http://frankscorner.org/wine/modules.php?op=modload&name=Sections&file=index&req=viewarticle&artid=22&page=1
> >
> >Hope this helps
> >
> >Thomas
> >
> >
> Ok - i've compiled up 20021031
> for kazaa lite 2.00 i get "you have uninstalled a part of Kazaa Lite 
> that is needed to run. Kazaa lite will now quit so you can re-install it."
> for 1.7.2 it almost works! the program launches and i see what looks 
> like the kazaa i know and love. then shortly afterwards i get an 
> unhandled exeption error and asks me do i want to start the debugger. 
> either option stops it from working
> here's the start of the errors:
> fixme:win32:PE_CreateModule Unknown directory 15 ignored
> err:menu:MENU_ParseResource not a string item 0800
> ...
> lots of the same
> ...
> then a whole pile of stuff like this:
> fixme:hook:NotifyWinEvent (32769,0x00010026,-4,8)-stub!
> ...
> fixme:ole:CoRegisterMessageFilter stub
> fixme:hook:NotifyWinEvent (32780,0x0003003f,-4,1)-stub!
> wine: Unhandled exception, starting debugger...
> err:seh:start_debugger Couldn't start debugger ("") (2)
> Read the Wine Developers Guide on how to set up winedbg or another debugger
> now the debugger worked fine from the rpm but doesn't work now. Would 
> getting it working provide more useful information?

Probably, but _I'm_ really not good at solving wine problems :)

> I can think of two possible reasons it wont work. One is that my system 
> (mandrake 9) is a gcc3 system and there's some sort of funny system call 
> or something *shrug*. The second is that i installed windows 98 as far 
> as the first reboot and then stopped it. perhaps this is causing the 
> problem? Unfortunately it wont boot here in work as it needs the via 
> 4in1 drivers for my motherboard. I'll bring the hard drive home this 
> weekend and should be able to get it to boot at home (although there are 
> complications with that too...) and finish the install process. I 
> thought the install was all done and there was only configuration left.

I use Mandrake 9, but unfortunately don't have the time to test it right
now.  I don't think the GCC issues would affect you, but I don't think
it would hurt to use the RPM version instead, and get the debugger up. 
Are you using 'fake windows', or trying to share an existing Windows
install?  I think Frank's info is referring to a fake install, but
copying over Windows DLL's.

> I really appreciate the effort you've gone to to help me and i'm more 
> than happy to try anything to get this working!

I hate not getting stuff working.. If I get a chance this weekend I'll
install Mandrake 9 at home (which I want to anyways, but never got
around to).. and see how far I get.


More information about the wine-users mailing list