Running Counterstrike - Half Life

Koby Leung koby at
Wed Oct 9 07:27:50 CDT 2002

Hey all,

	Two issues with HL-CS.
First, my system specs:

XFree 4.2.0 stock Redhat one - January 23. 4.2.0-8
Redhat 7.3 - WineX(and Wine 20020228)
512mb RAM
Matrox G400 card.

All my OpenGL stuff works(ie. HL in single player mode, with the nice voice 
over narration et al.)

So first issue: On startup, halflife complains that 
Could not open MCI file for playback: 266: There is an undetectable problem in 
loading the specified device driver.

The following line comes up if I run from console:
err:midi:OSS_MidiInit ioctl on midi info for device 0 failed.

Then I click ok twice, and it works. The sound effects work. I don't remember 
any musing in half life. While installing, the blowhorn sound effect played 
fine btw.

Issue two: This is the major one. 
I can get half-life to run normally under single player mode. CS doesn't work 
at all though. The menus come up, I can choose the map and all that, but then 
it just hangs. It gives the following error if I run wine from the command 
fixme:x11drv:SendGrabMessage grab window to big. can't grab to portion

Things I've tried:
Redhat Wine 20020228
	- These two came up with the same error as above. I'm now using WineX
Wine CVS(last night 20021009)
	Half life crashed. :(

I did the install using ./tools/wineinstall.

Any help would be greatly appreciated!



More information about the wine-users mailing list