(no subject)

Bub Slug bub1slug at hotmail.com
Fri Oct 18 11:16:43 CDT 2002

Hi All,

Wondering if there is a document that tells how to get wine printing through 
a cups printer working?  Yes I know the wine docs say it's all magic and if 
you're using cups your printing will magically work, but for some reason, it 
doesn't, my wine session crashes and burns when I try to print from the 
built in notepad (or any other apps I've tried: in particular, Lotus Notes 
5.0.11, but I don' think thats important yet).

I'm trying to print to an HP 1220C using Redhat 7.3 and RedHat 8.0 (on the 
same computer and on 2 different computers) I've tested cups printing, and 
it works fine, I can print from open office (for example) or I can simply 
get a prompt and type "lpr /etc/hosts" and that prints fine too.

I tried the wine's that are included in the RH 7.3 and RH 8 dists, and I've 
tried uninstalling those wines and trying :


And a couple of other older (from around June 2002) versions of wine.

The messages below are slightly different depending on which wine and which 
redhat, but the jist of them (at a terminal prompt) is:

	>wine notepad

and I get:

	>fixme:win32:PE_CreateModule Security directory ignored
	>fixme:win:SetWindowTextA cannot set text "Notepad - (untitled)" of other
		process window 0

Notepad starts fine, I can type, save the doc, open another doc, except when 
I try and print, in notepad I select:
	File > Print Setup

and I get:

	>fixme:commdlg:PRINTDLG_SetUpPrinterListComboA Can't find '(null)' in
		printer list so trying to find default
	>err:psdrv:PSDRV_FindPrinterInfo Error 2 getting PPD file name for printer
		'HP DeskJet 1220C Printer'
	>err:commdlg:PRINTDLG_ChangePrinterA DocumentProperties fails on "HP
		DeskJet 1220C Printer"

In this dialog box, neither portrait or landscape are selected, so I click
one and get:

	wine: Unhandled exception, starting debugger...

Then I get my prompt back and notepad goes away.

If I just start notepad, type a few characters and try and print with
	File > Print . . .
I get

	fixme:commdlg:PRINTDLG_SetUpPrinterListComboA Can't find '(null)' in
		printer list so trying to find default
	err:commdlg:PRINTDLG_ChangePrinterA DocumentProperties fails on "HP
		DeskJet 1220C"

A print dialog box comes up, with the HP DeskJet 1220C selected in the 
"Name:" dropdown list.  The OK and Properties buttons don't do anything, and 
so I have to click 'Cancel" at which time I get:

	fixme:commdlg:PRINTDLG_UpdatePrintDlgA No lpdm ptr?
	fixme:commdlg:PRINTDLG_WMCommandA Update printdlg was not successful!
	wine: dialog.c:391: DIALOG_FilePrint: Assertion `printer.hDevNames!=0'

Aha!! (I thought) the notepad that's running is the built in one, so I'm 
going to try something else . . . How about the actual notepad.exe from a 
windows 98 box?  OK, get that file, put it on my redhat system, rename it 
(to be sure which notepad is executing, the one I just got, not the built in 
notepad, I named it bill.exe cause it's as frustrating as the software he 
produces) then tried:

	>wine bill.exe
	(The old notepad starts)

type a few characters, select File > Print and I get a dialog box that says:
	"Not enough memory to print.  Quit one or more applications to increase
	available memory, and then try again."

and at the prompt I get:
	err:commdlg:PRINTDLG_PaperSizeA Hmm ? DeviceCapabilities() DC_PAPERNAMES
		failed, ret -1 !
	Printing disabled in wine.conf or .winerc file
	Use "printer=on" in the "[wine]" section to enable it.
	err:dc:CreateDCA no driver found for wineps.drv

I click OK and get back to notepad, then I try

	File > Page Setup . . .

I get a whole bunch of messages like:
	fixme:commdlg:PRINTDLG_PS_WMCommandA loword (lparam) 40, wparam 0x40471,
	lparam 00040028, STUB mostly.

And then a Print dialog opens.  Then I click the "printer . . ." button:

	fixme:commdlg:PRINTDLG_PS_WMCommandA loword (lparam) 40, wparam 0x30471,
		lparam 00040028, STUB mostly.
	fixme:commdlg:PRINTDLG_PS_WMCommandA loword (lparam) 40, wparam 0xa0471,
		lparam 00040028, STUB mostly.
	fixme:commdlg:PRINTDLG_PS_WMCommandA loword (lparam) 40, wparam 0x40471,
		lparam 00040028, STUB mostly.
	err:commdlg:PRINTDLG_ChangePrinterA DocumentProperties fails on "HP
		DeskJet 1220C"

And a Print dialog box opens.  The "Name:" dialog box shows "HP DeskJet 
1220C", but the the properties button does nothing.  The OK button gives me:

	fixme:commdlg:PRINTDLG_UpdatePrintDlgA No lpdm ptr?
	fixme:commdlg:PRINTDLG_WMCommandA Update printdlg was not successful!

but the dialog won't close, so I have to click the "Cancel" button and I 

	fixme:commdlg:PRINTDLG_PS_WMCommandA loword (lparam) 38, wparam 0x30471,

At least this version of notepad doesn't crash, it just sits there, 
everything still works (Edit > Find . . ., etc. all work)

I have to exit it "gracefully" with File > Exit, answer the "Yes No Cancel" 
document has changed prompt, and notepad closes.


So much for my experiences, my configuration looks like:

My win.ini has only one printer, set up as:

	device=HP DeskJet 1220C,WINEPS,LPR:HP

	HP DeskJet 1220C=WINEPS,LPR:HP,60,60


		(The CUPS printer name is "HP")

My wine config has:
	"Lpt1" = "/dev/lp0"

	"LPT1:" = "|lpr"
	;"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
	;"LPT3:" = "/dev/lp3"

	(The HP is the CUPS default)

My system.reg has:

	4.0\\Drivers\\PS Driver] 1034954575
	"Configuration File"="wineps.drv"
	"Data File"="<datafile?>"
	"Dependent Files"=str(7):""
	"Help File"="<helpfile?>"
	"Monitor"="<monitor name?>"

	[System\\CurrentControlSet\\Control\\Print\\Printers\\HP DeskJet 1220C]
	"Default DevMode"=hex:48,50,00,00,00,00,00,00,00,00,00,00,00,00,00,
	"Description"="WINEPS Printer using CUPS"
	"Location"="<physical location of printer>"
	"Name"="HP DeskJet 1220C"
	"Print Processor"="WinPrint"
	"Printer Driver"="PS Driver"
	"Separator File"="<sep file?>"
	"Share Name"="<share name?>"

Like I said, the crash and burn (with the built in notepad) is happening on 
both versions of RedHat, with all the versions of wine I've downloaded.

My simple question then is "What am I doing wrong??"  (And more importantly, 
"what have I done to deserve this? ;-|")  Everything looks right to me, 
should I be looking at something else?  Is something wrong in all the above?

I'm at my wits end, someone please help me get wine printing.



This tagline is umop ap!5dn

Get faster connections -- switch to MSN Internet Access! 

More information about the wine-users mailing list