wine RPMs break rpm

Justin Findlay findlay at
Tue Dec 2 23:58:03 CST 2003

On Wed, 3 Dec 2003, nosp wrote:

> Have you tried rebuilding the rpm database?
> # rm -rf /var/lib/rpm/__*
> # rpm --rebuilddb
> # rpm -Uvh /usr/src/redhat/RPMS/i386/wine-*

I did, yes to be safe, or sure, or whatever.  The first time I tried to
install my local-built wine RPMs, rpm then hung and I killed it, no rpm
command worked at all, so I killed X and logged in again and rebuilt the
rpm database.  After all, killing an rpm process doesn't sound like a good

Now, I just rebuilt the RPM database again and then rebooted to ensure
sufficient RAM.  Upon rebooting, I installed the RPMs via rpm -U.  The
stack trace from rpm's segmentation fault included a call to a malloc(),
so thought I, it's having trouble allocating sufficient memory for it's
rpm-ish stuff.  free showed the system had allocated up the RAM (1.5Gb) to
near repletion, although the swap partation slept vacant, despite the
gallons and gallons of space there (3Gb).  I didn't save the rpm
segmentation fault stack trace or I would produce it here, and now that
the RPMs have successfully installed, it's probably beyond the scope, or
topic, of this list.  It sounds like an rpm bug to my newbie ears,
although I might not be clever enough to reproduce it and report it.  
Thanks for the help.


More information about the wine-users mailing list