Age of Wonders 2 Mouse Issue

Mike Carlson corfe at
Sat Feb 22 15:09:48 CST 2003

Age of Wonders 2 in wine has what appears to be probably a very simple
bug, but makes the game unplayable - the game does not recognize mouse
clicks at all.  This happens in both this release (2/19) and last
release (1/15), before that I have not tested, but I presume it has
never worked.

I'm not exactly an expert debugger :)  but I tried some tracing, and it
seems the game does not use direct input but regular windows mouse
messaging, through X11DRV_GetCursorPos() and the like.  The game has an
option for software mouse, and this results in an even worse situation -
the cursor will not move from the upper right portion of the screen, and
even that disappears after that portion of the screen is refreshed.

The graphics in this game appear perfect up to this point, the title
screen looks beautiful, but I can't click on anything - I don't believe
the main title accepts keyboard input (unless that isn't working
either).  The ONLY problem I have seen so far is the issues with the

I'm submitting this to wine-users in the hopes that perhaps a more
knowledgeable wine hacker can tell me how to provide more information
about this problem (I'm willing to try to spend some time on it - I know
C, but am very unfamiliar with the structure of wine), or to tell
everyone about a very blatant input problem in wine that perhaps could
fix more subtle problems in other programs.

- Corfe ( corfe at )

More information about the wine-users mailing list