Problems installing wine

Ken Sarkies ksarkies at
Mon Jul 7 02:40:52 CDT 2003

Hi wine-users

Apologies for sending the first email with the wrong return address.

I wonder if anyone can offer some advice. I have a RH8.0 installation on
which I was running wine-20021007 quite happily. I upgraded a number of
base packages and still wine ran beautifully. Knowing the changing face
of wine, I decided to upgrade. I did this with a binary distribution and
immediately ran into problems. I had forgotten that I installed the
original wine by compiling. After two days of downloading binaries and
source packages and fiddling I am still don't have confidence in my
wine. As an example of the problems experienced, I first made sure I had
uninstalled all versions of wine and worked through all places where I
could identify anything relating to wine and deleted it. I then did a
vanilla compile of wine-20030618. When I ran wine, it told me that it
could not find /usr/lib/wine/ The directory in fact doesn't
exist because the compiled wine puts everything under the prefix
/usr/local, not /usr. Why is wine picking up this prefix (which is the
one apparently used by the RH distributions)? Same thing happened with
the previous version 20030508, which I am now using.

I did a symlink to this "odd" directory and wine starts OK, but still
some of my working applications crash after getting part of the way
through (this may be because I haven't fully worked through the
reconfiguration yet) - OK another reinstall and now they don't crash!! -
probably an old registry. It is now quite usable, but I would like to
get to the bottom of the "hassles" just to have some confidence.

Is there something I haven't purged properly?

cheers, Ken

PS many many thanks to the developers of this package - it means I can
do all my work from Linux with just the one major application - a Web
editing tool - that needs Windoze.

More information about the wine-users mailing list