A newbie needs help with Wine...

Fred M. Sloniker fizzit at pioneernet.net
Sun Jul 13 20:54:19 CDT 2003

I'm using the version of Wine that SuSE 8.2 includes; I'm willing to upgrade, 
but only if it actually fixes the problem I'm having.  n_n  (I'm nervous about 
compiling things.)

My goal was to play Moonbase Commander on my SuSE box (it's a dual-boot 
machine, with Win98 on the other side, but I don't want to have to reboot 
just to play a quick game), so I started by tossing Progress Quest onto the 
box as a test that Wine worked at all.  It worked, mostly; a graphical glitch 
appears when a list becomes long enough to need to vertically scroll, and for 
some reason no armor items appear in my equipment list, only the weapon item.  
Oh, and I get a TON of "fixme:commctrl:FlatSB_SetScrollProp stub" errors in 
the terminal window.  I'd appreciate help with these problems, but they're 
not my primary concern.

I went on to try to install Moonbase Commander; it died for no apparent reason 
the first time, but a second try was successful.  Attempting to start it, 
however, causes my resolution to change to about 640x480 and pops up the 
Moonbase Commander window, only I can't click on anything and my mouse 
pointer is still the SuSE mouse pointer.  Killing the process leaves the KDE 
window a 640x480 glimpse of my desktop, and I have to log out and back in to 
fix it, but I suppose that's to be expected.  So what do I need to do to fix 
this problem?  As I mentioned, I have a Win98 install in case I need to point 
to some official DLLs or something.

While I'm asking, one quick question: can I run QBasic under Wine?  If so, 
how?  My first attempt spit out a handful of errors, and subsequent attempts 
have produced a screenful of QBasic help rather than putting me in the 

More information about the wine-users mailing list