Using flash.ocx in apps

Ernesto Baschny ernst at
Wed Jul 16 12:04:59 CDT 2003


On 16 Jul 2003 at 1:09, Sylvain Petreolle wrote:

> it seems flash isnt correctly installed.
> what about to try installing it with the real installer ? I didnt
> manage to install it that way.

The Macromedia's flash installer didn't worked here for me because I 
have no IE installed. The "alternate" installer requires Netscape or
some kind of browser to be installed. But it seems that registering
the activeX component with regsvr32.exe should be correct. 

I now noticed that everything works, just playing won't work. I can
see in the "Movie Info" dialog that the plugin was able to detect the
movie size (width, height), frame rate, and even the version of the
macromedia flash plugin that is installed ("6"). So it seems to me 
that the communication with flash is working, just showing the
movie isn't.

> note: the player installer has problems with directories, it creates a
> "c:\program\ files?\swiff" directory...

Here the application installed correctly in "C:\Program Files\
GlobFX Technologies\Swiff Player\" as SWFPlayer.exe. 

I am using fake_windows btw.

Does your SWFPlayer.exe start and is it able to open some .swf 
file and show the info in the File->Movie Information dialog?

Thanks for your help. :)

> > I am trying to make use of macromedia's flash.ocx ( with the
> > application 
> > 
> > I registered flash.ocx on wine with regsvr32.exe and installed the
> > Swiffplayer application, and after that the SWFPlayer.exe starts ok.
> > 
> > Then I try to load a swf-file (a movie), but it doesn't play
> > anything.
> > The movie frame remains blank and neither play nor scroll the movie
> > will
> > work.
> > 
> > I really tried a LOT of combinations of buildin/native DLLs with
> > no effect.

Ernesto Baschny <ernst at> - PGP:
 Sao Paulo/Brasil - Stuttgart/Germany
 Ernst at IRCnet - ICQ# 2955403

More information about the wine-users mailing list