Wrong USER.EXE and nothing working...

James role.wine at axoria.net
Mon Oct 20 13:15:07 CDT 2003

On Mon, 2003-10-20 at 18:29, Duane Clark wrote:

> I don't really know the intricacies of rpm. But I think that Redhat
> puts  the libraris and binaries in a different location from other
> RPMs. So I am mostly concerned that those other did not get deleted.
> And from your symptoms, it sounds like some old files are still
> around.
> So I would check to verify that the old ones really were deleted. I
> would also check the file /etc/ld.so.conf. This file contains a list
> of  paths where Linux will look for libraries. Check each path and see
> if  any old Wine libraries are around. Also make sure that it contains
> the  path to your current Wine libraries.
> You might also try setting an environment variable to point to the 
> directory containing the "secondary" Wine DLLs 
> WINEDLLPATH=/usr/local/lib/wine (or whatever)

Thank you for your comments.

I have tried your suggestions, and still no luck...

The /etc/ld.so.conf seems to contain the correct reference, but I tried
setting the WINEDLLPATH too (like 'export WINEDLLPATH=/usr...' etc.) and
that made no difference.

It may be helpful to note that the initial problem with 'USER.EXE' that
I reported is actually solved by fixing all the configs in ~/.wine and
the stumbling block I am really hitting is the Unhandled Exception in
thread 0009, or some such -- details in my original email.

Since I've noticed some other people experiencing this error, and
because it happens so early, regardless of what I am trying to launch
(whether notepad or some application of my choosing), I can't help
thinking from my programming experience that the developers will spot
the problem as something obvious, perhaps configuration-related.

Do developers read this list enough to see the comments, or would I be
better-advised to ask on the developers list perhaps?

I'm keen to help solve Wine problems as much for the community as for
getting my own installation working -- if I can be guided to run any
additional specific tests to get to the bottom of exactly what is wrong,
I'd be happy to try and help if I can :)

Best regards,

More information about the wine-users mailing list