[Wine]Partially working app broke when wine configured

michael at cherryblossom.homelinux.com michael at cherryblossom.homelinux.com
Thu Aug 12 18:35:42 CDT 2004

On Thu, Aug 12, 2004 at 04:24:36PM -0700, Rich Shepard wrote:
>   Host system: wine-20040716-nodebug on Slackware-10.0 with 512M RAM.
>   I just installed the latest wine. Had to use the tarball source to get
> ~/.wine and all its components, then used the Slackware package to install
> the application. Did not run winecfg at this point.

~/.wine is usually autogenerated when you run wine or wineconfig for the
first time, right?  And you might want to check for diffs between your
package and the sources -- especially if they're different releases,
which may have vast differences... you should either use the package or
the source, not both intermingled, right?

>   The application I'm trying to run is a proprietary one (in the sense that
> it was never widely sold, if sold at all). The application I'm trying now to
> run is the demo version (tflops.exe). Wine fired up just file and I could
> load a model file in the tflops.exe window. However, when I tried to run the
> demo model, the tflops.exe tried to call flops.exe but wine reported that it
> could not run the second file.

Maybe poorly written app?  Can you give us some info on the debug

>   Thinking that I needed to configure wine so it see the second executable,
> I fired up winecfg. I added the two .exe files, specified win98 and dos6.22
> in the appropriate places and removed the "z:\" drive (/ on the linux box).
> The virtual "c:\" drive is ~/.wine/drive_c/. As soon as I accepted the
> changes to winecfg and closed the dialog box, wine refused to start. It
> tells me that it cannot find the DOS drive on the '/' directory, that
> "c:\\windows" and its subdirectories are not accessible and other errors.
>   What do I do to restore the working configuration I had?

Didn't you back up ~/.wine/config ?  If not, can't you just reextract
your ~/.wine configuration files from your source tarball?
>   Then, how do I debug the reason why the one .exe cannot seem to invoke the
> second .exe on the same "drive"?

Oh, so *that's* why you didn't include debug input... try looking at
manpages for wine and winedbg, I believe, shall help you.  As they say,

> TIA,
> Rich
> -- 
> Dr. Richard B. Shepard, President
> Applied Ecosystem Services, Inc. (TM)
> <http://www.appl-ecosys.com>
> _______________________________________________
> wine-users mailing list
> wine-users at winehq.org
> http://www.winehq.org/mailman/listinfo/wine-users

Good luck.

More information about the wine-users mailing list