[Wine]printing problems

Jack terminlman at yahoo.com
Fri Aug 20 12:00:39 CDT 2004

I've installed wine 20040716, compiled from source tarball, on an LFS
(linux from scratch) system.  I print using lpr, which just copies the
output (assumed postscript) to /dev/lp0.  No CUPS, not /etc/printcap.

I've checked the user manual, and tried various combinations of entried in
various files, but I'm obviously missing something, because even in
Notepad, there are no listed printers (even to file).

~/.wine/dosdevices/lpt1: is a symlink to /dev/lp0

in ~/.wine/config I have

"FILE:" = "tmp.ps"
"LPT1:" = "|lpr"

# "ps1" = "/usr/local/share/wine/apple380.ppd"
"ps1" = "/usr/local/share/wine/generic.ppd"

# "ps1" = "/usr/local/share/wine/apple380.ppd"
"ppdfile" = "/usr/local/share/wine/generic.ppd"

win.ini now has

device=Wine PostScript Driver,WINEPS,LPT1:

Wine PostScript Driver=WINEPS,LPT1:

device=Wine PostScript Driver,WINEPS,LPT1:,15,45

Finally (and I think this is probably where my main problem is) system.reg

[System\\CurrentControlSet\\Control\\Print\\Environments\\Windows 4.0\\Drivers\\PS Driver] 1093020050
"Configuration File"="wineps16"
"Data File"="<datafile?>"
"Dependent Files"=str(7):""
"Help File"="<helpfile?>"
"Monitor"="<monitor name?>"

[System\\CurrentControlSet\\Control\\Print\\Printers] 1093019548

I have tried deleting the last section (there is no content to that
section) and it just recreates the empty section.  I've seen some
suggestions to edit wine.inf (not clear whether in the source area or the
installed copy) but I can't find any template of how to enter the required
information, and I obviously don't want to play with the registry unless
it's clear what I'm doing.

Any hints as to what I'm missing would be appreciated.


More information about the wine-users mailing list