[Wine]Solidworks: cannot find a proper pixel format

Johan De Groote johan.de.groote at skynet.be
Wed Dec 8 14:52:59 CST 2004

Took the cdrom from office and tried to run it on Wine (20040121). (before 
sneaking a linux setup in the office...) Wine was installed on a pure linux 
system, without any MS directory/filesystem/files.

The installation went without any problems or errors. 
I can start the program, and then I get in the terminal the following message:

"ERROR: You need to merge the 'winedefault.reg' file into your
       Wine registry by running: `regedit winedefault.reg'"

Since I cannot find regedit anywhere, this may be the cause of the problem, 
but this is the only application giving this error. Do I have to take it from 
a windows cd?

After a few flickers of the opening window I have the program open. I can 
start a new part or open an exsisting one. Drawing a line and so on works, 
but once I do something that will manipulate the 3D object I get the 
following message: "cannot find a proper pixel format" and then the 
application (and wine) hangs.

The pc uses an ATI9200 with the drivers coming with the kernel for DRM 4.1 ATI 
Radeon.  As far as I can see, I'm using Xfree86 4.3.0. In the XF86Config I 
find the following:

"# Device configured by xf86config:

Section "Device"
    Identifier  "hercules 3d prophet 9200"
    Driver      "radeon"
    #VideoRam    131072
    # Insert Clocks lines here if appropriate

Looks ok to me. If I run the fglrxinfo utility from ATI, then I get the 

"bash-2.05b# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4"

So while this is not the ATI opengl diver, there is an opengl driver active.

Can anyone putting me in the right direction?

More information about the wine-users mailing list