[Wine]GTA3 problems

Grahame White grahame at regress.homelinux.org
Thu Dec 23 00:57:30 CST 2004

I'm using the current cvs version of wine and have been using Grand Theft 
Auto 3 for a month or so with only a few issues. After updating and 
recompiling wine last night I encountered a pretty major problem, cut 
scenes refuse to end. They play through alright, but when it comes to the 
end of the scene the game doesn't resume.

Out of curiosity I backed up my ~/.wine directory and used 
tools/wineinstall and then proceded to reinstall gta3. Or at least I tried 
to reinstall it. Before the update installation was as simple as running:

$wine /cdrom/Setup.exe

now running that produces the following output:
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:ITypeInfo_fnRelease destroy child objects

[last line repeats about 30 times or so]

fixme:ole:ITypeInfo_fnRelease destroy child objects
wine: Unhandled exception (thread 0010), starting debugger...
WineDbg starting on pid 0xc
Unhandled exception: page fault on read access to 0x00000020 in 32-bit code 
In 32 bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
 EIP:40af5edf ESP:41aa4ec0 EBP:41aa4f54 EFLAGS:00010246(   - 00      
 EAX:00000000 EBX:40b26910 ECX:41aa4f14 EDX:416a0710
 ESI:40b267eb EDI:40b1c934
Stack dump:
0x41aa4ec0:  416a0710 40b1c924 41aa4f14 00000000
0x41aa4ed0:  00000020 40b26910 00000000 403c8e68
0x41aa4ee0:  403c8e6a 40b26910 00000018 00000000
0x41aa4ef0:  41aa4f1c 40af1e44 41aa4f14 00000018
0x41aa4f00:  00000000 41aa50dd 41aa4f9c 416a0710
0x41aa4f10:  40b26910 416a0710 00000000 41aa4f54
=>1 0x40af5edf StdMarshalImpl_MarshalInterface+0xbf(iface=0x403e9d00, 
pStm=0x403c8e40, riid=0x40b1c934, pv=0x416a0710, dwDestContext=0x0, 
pvDestContext=0x0, mshlflags=0x0) 
[/home/grahame/wine/dlls/ole32/compobj_private.h:180] in ole32 
  2 0x40af749c CoMarshalInterface+0x26c(pStream=0x403c8e40, 
riid=0x40b1c934, pUnk=0x416a0710, dwDestContext=0x0, pvDestContext=0x0, 
mshlFlags=0x0) [/home/grahame/wine/dlls/ole32/marshal.c:716] in ole32 
  3 0x40ae335a _LocalServerThread+0x1ea(param=0x403c9c88) 
[/home/grahame/wine/dlls/ole32/compobj.c:1136] in ole32 (0x41aa51b0)
  4 0x4052b3ba THREAD_Start+0x11a(ptr=0x403c8e40) 
[/home/grahame/wine/dlls/kernel/thread.c:107] in kernel32 (0x41aa5288)
  5 0x401e82e3 start_thread+0x1a3(info=0x403c9cb8) 
[/home/grahame/wine/dlls/ntdll/thread.c:200] in ntdll (0x41aa5ad8)
  6 0x4004ab63 start_thread+0x93 in libpthread.so.0 (0x41aa5b4c)
  7 0x4012dc4a __clone+0x5a in libc.so.6 (0x00000000)
0x40af5edf StdMarshalImpl_MarshalInterface+0xbf 
[/home/grahame/wine/dlls/ole32/compobj_private.h:180] in ole32: movl    
180     {
WineDbg terminated on pid 0xc
err:ole:get_unmarshaler_from_stream Failed to read common OBJREF header, 
fixme:ole:CoCreateInstance no classfactory created for CLSID 
{91814ec0-b5f0-11d2-80b9-00104b1f6cea}, hres is 0x8003001e

I thought that perhaps this was due to not having DCOM98 installed so I 
installed it and tried again with the same output.

Any ideas? Should I submit this as a bug to bugzilla?


More information about the wine-users mailing list