Do i even have DGA?

motub at motub at
Wed Feb 4 04:38:53 CST 2004

cedric wrote:

>I'm sorry for not searching the archives first, but i have a dial-up
acces and 
>try to minimize online time.
>Hi, i try to enable DGA on my box, in order to get more dhan 1 fps on 
>starcraft. I looked at the config file and noticed the following section:
>; Use XFree86 DGA extension if present
>; (make sure /dev/mem is accessible by you !)
>"UseDGA" = "Y"
>I made sure i have complete acces to /dev/mem (and everybody else)
>;crw-r-----    1 root     kmem       1,   1 Jan 23 17:29 /dev/mem #ori
>;crw-rw-rw-    1 root     kmem       1,   1 Jan 23 17:29 /dev/mem #new
>This didn't solve the problem. 
>Then i run glxinfo |grep dga. No output. I guess i don't have DGA
>Furthermore, it's not being loaded at startx:
>>From X config:
>Section "Module"
>        Load  "extmod"
>        Load  "glx"
>        Load  "dri"
>        Load  "dbe"
>        Load  "record"
>        Load  "xtrap"
>        Load  "speedo"
>        Load  "type1"
>When i run starcraft like this i get a warning regaring dga:
>bash-2.05b$ wine --debugmsg +x11drv wine-c-drive/Program\ Files/Starcraft\ 
>err:font:ReadFontDir Can't open directory 
>Fontconfig error: line 24: not well-formed (invalid token)
>Fontconfig error: Cannot load default config file
>trace:x11drv:x11drv_init_thread_data X display of IM = 0x3c024e48
>trace:x11drv:x11drv_init_thread_data Using C locale of Input Method
>warn:x11drv:X11DRV_XF86DGA2_Init disabling XF86DGA2 (insufficient 
>trace:x11drv:X11DRV_CreateBitmap (0x54) 32x32 1 bpp
>trace:x11drv:X11DRV_CreateBitmap (0x58) 32x32 1 bpp
>trace:x11drv:X11DRV_GetBitmapBits (bmp=0x403898a0, buffer=0x403898f4, 
>trace:x11drv:X11DRV_GetBitmapBits (bmp=0x40389858, buffer=0x40389974, 
>trace:x11drv:X11DRV_CreateBitmap (0x5c) 32x32 1 bpp
>trace:x11drv:X11DRV_CreateBitmap (0x60) 32x32 1 bpp
>trace:x11drv:X11DRV_GetBitmapBits (bmp=0x40389b80, buffer=0x40389bd4, 
>trace:x11drv:X11DRV_GetBitmapBits (bmp=0x40389b38, buffer=0x40389c54, 
>trace:x11drv:X11DRV_CreateBitmap (0x64) 7x11 1 bpp
>trace:x11drv:X11DRV_CreateBitmap (0x68) 36x18 24 bpp
>trace:x11drv:X11DRV_CreateBitmap (0x84) 512x16 24 bpp
>trace:x11drv:X11DRV_CreateBitmap (0x88) 512x16 1 bpp
>Can somebody tell me why dga isn't working? Do we need more info on this?
>Greets, cedric

Yes, more info is definitely needed. What is your video card? If you
have an nVidia or ATI card, you may still be using the VESA drivers
(often used as the default until the user installs the proprietary
closed-source manufacturer drivers), which do not enable 3D hardware
acceleration (which is OpenGL and DGA). I have an ATI card, and I did
notice that even under VESA, glx et al were still listed as modules to
be loaded in XF86Config-4, so the fact that it is there is not proof
that it's actually working.

Can you look further in the XF86Config(-4) file and tell us which driver
your videocard is using?

Hope this helps,
Holly Bostick

More information about the wine-users mailing list