Wine sound problems

Richard W. Knight rick_knight at
Mon Feb 23 12:26:57 CST 2004

No OSS sound from wine after replacing my mainboard and CPU. The old 
board had Yamaha YMFPCI based onboard audio, the new board uses an 
Intel8x0. I'm running ALSA (1.0.2c) and I've rebuilt ALSA for the new 
board and rebuilt wine (20040121) with the new ALSA.

Where I need sound in wine is with Unreal (the original) and Half-Life. 
Unreal plays great except that I have no sound at all with the 
wineoss.drv. If I set wine config to use winealsa.drv I get great music, 
but the effects lag action by about a second or so. If I use 
winearts.drv I get great music but no effects. Half-Life is locking up 
where it seems to be starting sound. I did get sound from wineoss two 
nights ago, but now nothing and I can't recall changing anything.

I've tried the December and October (2003) builds of wine and the 
previous release of ALSA. No difference.

I know about the new linux installer for Unreal, but it requires UT, 
which I don't have and don't really want, so it's not much of an option.

Sound in Linux is great, sound in dosemu is OK (no music, just effects). 
The output of /proc/asound/oss/sndstat looks as it should.

Can anyone tell me how to fix the Arts or ALSA problems or how to get 
sound from OSS?

BTW I'm using kernel 2.6.2/Slackware 9.0. I tried kernel 2.4.20 but that 
also made no difference.

Rick Knight
(rick at

More information about the wine-users mailing list