[Wine]Can't load X dll...

Dave Washburn dwashbur at nyx.net
Tue Jul 20 14:48:40 CDT 2004

On Tuesday 20 July 2004 13:27, Stefan Munz wrote:
> > > Am Dienstag, 20. Juli 2004 03:54 schrieb Dave Washburn:
> > > > My question is both general and specific.  First the specific: I'm
> > > > trying to run Logos 2.0 Bible software under the latest release of
> > > > wine that I got and installed from cvs about 2 days ago.  That
> > > > release cured a lot of my woes (thanks to all who pointed me that
> > > > way) but now when I try to run this particular program, it keeps
> > > > telling me it can't load a particular DLL, specifically LEAD20.DLL
> > > > which is part of the Logos package.  I've checked my wine.conf for
> > > > the location of the system folder and made sure the file is there;
> > > > when that didn't work I copied the file to the program's own system
> > > > folder, and I just keep getting the same message.  I checked my
> > > > Windows machine and found a couple of lines in the win.ini that
> > > > weren't in my Linux one, so I added those and tried again.  No help.
> > > > What's the next step?
> > >
> > > I assume you didn't you install the program in wine, but copy it from
> > > your windows machine. I could solve some dll issues by exporting the
> > > registry under windows and importing it in wine.
> >
> > You assume correctly.  What's the process for doing this with the
> > registry on the Linux/wine end?
> just copy the (exported) windows registry file to your fake_win dir, start
> regedit ("wine regedit") and import it. maybe a "reboot" of wine is needed
> ("wineboot").

Hmm, okay, here's the situation.  The registry file I needed to import is 
in /windows/windows, which is a complete copy of the windows directory and 
all its subs from the other machine.  I'm assuming, perhaps incorrectly, that 
using the regedit in the source-code "programs/regedit" dir will edit the 
registry that's in my ~/.wine directory, am I correct?  So, I went 
to /windows/windows, ran "wine ./regedit" and exported the registry to a file 
I called windows_dir.reg in my home dir.  Then I went to 
~/wine/programs/regedit, ran the regedit there and imported the file.  Did I 
do this right?

Because the program still doesn't work, it stops with the same error :-(  I'm 
really hoping that I did something wrong, because I can fix that.  If the 
program is just being recalcitrant, I really can't do much about that.  I'd 
rather the problem was something I can fix!

> > > One other (maybe obvious) possibility is that the permessions on the
> > > copied dll file are wrong.
> >
> > Nope. I checked that :-)  Still, it never hurts to ask; part of my
> > personal philosophy is, the answer is always simpler than we think it is.
> maybe not always but more often than we think ;-)

The older I get, the more I realize that it's usually something I overlooked 
in my ADD-induced haste :-)

Dave Washburn
Insert clever epigram here...or not

More information about the wine-users mailing list