Compile error?

Kai OM epimetreus at
Mon Mar 29 19:22:40 CST 2004

Hey folks. First time I've mailed the list, so hopefully this isn't a
really simple question that I should already know.

I downloaded the Wine source into my home directory, using CVS, exactly
as outlined in the Wine documentation, then tried to make it with
./configure && make depend && make

This is the error message I get during compile -- I went back and
manually tried to compile the same code after the make failed to recreate
the error; here are the results:

$ cd /home/morlun/src/wine/dlls/d3d8
~/src/wine/dlls/d3d8$ gcc -c -I. -I. -I../../include -I../../include
-I/usr/X11R6/include -D__WINESRC__ -D_REENTRANT -fPIC -Wall -pipe
-mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+
-Wpointer-arith -g -O2 -o directx.o directx.c
directx.c: In function `IDirect3D8Impl_GetDeviceCaps':
directx.c:639: `GL_MAX_VERTEX_UNITS_ARB' undeclared (first use in this
directx.c:639: (Each undeclared identifier is reported only once
directx.c:639: for each function it appears in.)

I've reinstalled Mesa, following the README and INSTALL files, as well as
my video drivers, which also have OpenGL support.

The same error persists. Does anyone know what is supposed to declare
that function so I can try and see if it's present in my system?

More information about the wine-users mailing list