Warcraft 3 Copy Protection (regression?)

Aneurin Price alp108 at student.cs.york.ac.uk
Sun May 16 07:35:01 CDT 2004

I recently patched Warcraft 3 to 1.15, and decided I might as well try 
running it without a no-cd patch. To my surprise, it whirred for a bit 
and then detected the CD, which had never worked before. I don't know 
whether the difference was something about the version of WC3, or 
because I'd just upgraded to a 2.6 kernel, or because of the Wine 
version (20040309), but having upgraded Wine to 20040505 it no longer 
works. I've set up the devices symlinks and tried using both a new 
config file and the old one with the drives setting removed (as 
suggested by Wine's output), but I still have to use a crack again now. 
It's not the end of the world, but it did seem really cool for about 3 
days:-(. Any idea why this would be? I don't really know what was 
changed recently with the alterations to the way drives are set up...
Anyway, thought it might be worth mentioning,
Aneurin Price.

More information about the wine-users mailing list