Warcraft 3 Copy Protection (regression?)

Aneurin Price alp108 at student.cs.york.ac.uk
Sun May 16 17:48:16 CDT 2004

Aneurin Price wrote:
> Saulius Krasuckas wrote:
>> Aneurin Price wrote:
>>> I presume a similar thing is happening with 20040505, since after
>>> checking (by just running an app and looking in the open file dialogue)
>>> I've discovered that the contents of the cd aren't being read, so it
>>> must need the device symlink to point to the mount point. How then would
>>> one also provide it with the device as could previously be done using a
>>> "Drive" entry in the config file?
>> man wine says:
> <some relevant and important stuff>
> My apologies; I should have noticed that. I'll try that out just as soon 
> as I can get WC3 to work again (it blew up and now won't re-install).

So (this is really just a FYI, since it's working for me now)...
Eventually got WC3 to install after much swearing (I think my disk is 
*slightly* too scratched to be happy). Then installed Frozen Throne.
At this point I was using a version of Wine compiled from CVS today.
Trying to run the game (version 1.07 as of a fresh install of the 
expansion) failed in the same way as the copy protection problem, though 
it *could* have been caused by something else as the only symptom is 
that it fails to run and there are no error messages :(. I tried to 
patch it to 1.15 and the patcher died horribly.
I then uninstalled Wine and installed the package in Debian testing 
(20040309). The game then ran quite happily (with the movies directory 
renamed, as trying to play them makes the game crash), as did the 
patcher. As a side note, the CD did not have to be mounted, as long as 
it was in the drive. Having patched WC3 to 1.15, I then uninstalled Wine 
and replaced it with the CVS version. WC3 now runs without problems 
(still no movies, but that's a different issue), though oddly the cdrom 
now needs to be mounted.
I couldn't say whether the problems with the current CVS are because 
I've done something wrong compiling it, which was okay with the deb 
package, or if something's actually changed. I'll probably downgrade my 
CVS copy tomorrow and see if I can figure out what's going on.

More information about the wine-users mailing list