[Wine]Problems with installing a program

Mark Knecht markknecht at gmail.com
Fri Nov 12 09:20:00 CST 2004

On Fri, 12 Nov 2004 16:03:48 +0100, Holly Bostick <motub at planet.nl> wrote:
> rainer.koecher at ok-automation.at wrote:
> >
> > Hello,
> >
> > I tried to install an Application named "GX IEC Developer" in wine.
> > The setup program is named setup.exe. so i typed the following line on
> > the console
> >
> > rainer at 192 <mailto:rainer at 192>:~> wine D:\\start.exe
> >
> > The first Dialog box of the installation programm appears, but i can't
> > do anything with it. Here is the console output.
> >
> > fixme:ole:CoRegisterMessageFilter stub
> > fixme:ole:OLEPictureImpl_Construct Unsupported type 3
> > fixme:ole:OleLoadPictureEx
> > (0x4133e0ac,28990,1,{7bf80980-bf32-101a-8bbb-00aa00300cab},x=0,y=0,f=0,0x406cfad8),
> > partially implemented.
> > fixme:ole:OLEPictureImpl_get_hPal (0x4038fc10)->(0x406cfa84): stub
> >
> >
> OK, maybe I'm dim, but if the setup program is named "setup.exe", why
> did you run "start.exe"?
> Secondly, did you try running the setup from within the directory itself
> (cd to the directory containing the program), and if so, was there any
> change in the output?
> Holly

I think this is an interesting issue. I *think* I'm seeing different
results with Wine on some setup programs based on which if the
following I do:

1) cd ~mark; wine /mnt/cdrom/install.exe

2) cd /mnt/cdrom; wine install.exe

3) cd ~mark/.wine/dosdevices/c:/; wine /mnt/cdrom/install.exe

The problem I am sometimes seeing is this issue that came up in an
email a few weeks again where there seem to be file permissions

warn:file:CreateFileW Unable to create file L"C:\\desktop.ini" (status c0000034)
trace:file:CreateFileW returning 0xffffffff
trace:file:FindFirstFileExW L"C:\\PROG~FBU" 0 0x77acd930 0 (nil) 0
trace:file:RtlGetFullPathName_U (L"C:\\PROG~FBU" 520 0x77acd67c 0x77acd8e0)

In the line immediately above the path should have been c:\Program
Files, or some 8.3 automatically created version of that. However,
depending on where I run from I seem to get different failures.

trace:file:wine_nt_to_unix_file_name L"\\??\\C:\\" ->
trace:file:FindNextFileW 0x77c52418 0x77acd930
trace:file:NtQueryDirectoryFile (0x54 (nil) (nil) (nil) 0x77acd884
0x77c5244c 0x00002000 0x00000003 0x00000000 L"PROG~FBU" 0x00000000
trace:file:append_entry long L"."... short L""... mask L"PROG~FBU"
trace:file:match_filename (L"."..., L"PROG~FBU")
trace:file:append_entry long L".."... short L""... mask L"PROG~FBU"
trace:file:match_filename (L".."..., L"PROG~FBU")
trace:file:append_entry long L"windows"... short L""... mask L"PROG~FBU"
trace:file:match_filename (L"windows"..., L"PROG~FBU")
trace:file:NtQueryDirectoryFile => 80000006 (0)
trace:file:FindFirstFileExW L"C:\\PROG~FBU" not found

Does anyone have a definitive statement about which of the 3 ways
above (or some other way !) is the right way to do an install under

- Mark

More information about the wine-users mailing list