[Wine]zoom flash upgrade via serial port with wine

edmond at tec.tecd edmond at tec.tecd
Sat Oct 9 19:12:53 CDT 2004

Wine version:  Wine 20040914

"Com1" = "/dev/cua0, 38400"
"Com2" = "/dev/ttyS1, 38400"
"Com3" = "/dev/ttyS2, 38400"
"Com4" = "/dev/modem,  38400"

I added the 38400's later.

I have been trying to run a zoom modem flash upgrade application
on Linux with wine (No native windows software).

My config file is set up.  My protections are wide open for
/dev/cua0 /dev/ttyS0.  My ~/.wine/dosdevices/com* files are
linked in the same way as my config file shows them to be.

I can talk with the modem from minicom via Linux on the same
account I am running wine.

I did not do anything with "win.ini".  Other than trying to talk
to the modem, the software runs very clean.  No strange messages
from wine like "fix me" or bug messages.  It just tells me the
modem is not responding.  Maybe it really is not.  At times I
notice the "TR" flash just once. when I run it, but never the
"RD" receive data light, which normally flashes when one talks
with the modem.

I have tried to download several free terminal packages to test
the modem under wine, but they all seemed to have dll issues like

I then searched google and found an article from someone that
they had indeed made similar Zoom software I am trying to use
work on a "wine only" Linux box.  It is possible that the
software is working as it should and there is some other mismatch
between the software and what the modem is willing to do.

If anyone has any comments please let me know.  Or if you can
advise on a free terminal to talk with the modem that will run
under wine.

Just in case someone has done this already, the modem is a Zoom
2949L modem which I am trying to update to include new V.92

More information about the wine-users mailing list