[Wine]Guild Wars Client

Mark Knecht markknecht at gmail.com
Fri Oct 29 13:40:08 CDT 2004

On Fri, 29 Oct 2004 10:11:53 -0700, Mark Knecht <markknecht at gmail.com> wrote:
> On Fri, 29 Oct 2004 11:46:10 -0500, Joel Konkle-Parker <jjk3 at msstate.edu> wrote:
> > I'm attempting to use the Guild Wars Client to see if it will work on
> > WINE, but it keeps displaying an error about not being able to write to
> > the proper directories. I told it to install in C:\Program Files, and my
> > .wine/fake_windows/* folders all seem to have correct permissions.
> >
> > Any ideas why this would happen?
> >
> > The client is only a 60k download (it downloads the rest itself):
> > http://www.guildwars.com/preview/wpe-clientdownload.html
> >
> I was trying to install GigaSampler LE the other day and ran into
> something very simiilar. The installer created c:/Program
> Files/GSampler, but then couldn't create c:/Program
> Files/GSampler/some-directory. Permissions were fine as far as I could
> tell.
> - Mark

I just tried another game - Roller Coaster Tycoon - and got the same
failure I saw with GigaSampler. I then ran it under the debugger and
got more info. Same failure I saw before:

trace:file:RtlGetFullPathName_U (L"C:\\desktop.ini" 520 0x77acd5b4 (nil))
warn:file:wine_nt_to_unix_file_name L"desktop.ini" not found in
warn:file:CreateFileW Unable to create file L"C:\\desktop.ini" (status c0000034)
trace:file:CreateFileW returning 0xffffffff
trace:file:FindFirstFileExW L"C:\\PROG~FBU" 0 0x77acd930 0 (nil) 0
trace:file:RtlGetFullPathName_U (L"C:\\PROG~FBU" 520 0x77acd67c 0x77acd8e0)
trace:file:wine_nt_to_unix_file_name L"\\??\\C:\\" ->
trace:file:FindNextFileW 0x77c52418 0x77acd930
trace:file:NtQueryDirectoryFile (0x54 (nil) (nil) (nil) 0x77acd884
0x77c5244c 0x00002000 0x00000003 0x00000000 L"PROG~FBU" 0x00000000
trace:file:append_entry long L"."... short L""... mask L"PROG~FBU"
trace:file:match_filename (L"."..., L"PROG~FBU")
trace:file:append_entry long L".."... short L""... mask L"PROG~FBU"
trace:file:match_filename (L".."..., L"PROG~FBU")
trace:file:append_entry long L"windows"... short L""... mask L"PROG~FBU"
trace:file:match_filename (L"windows"..., L"PROG~FBU")
trace:file:NtQueryDirectoryFile => 80000006 (0)
trace:file:FindFirstFileExW L"C:\\PROG~FBU" not found
trace:file:FindNextFileW 0x77c503d8 0x77acef40
trace:file:NtQueryDirectoryFile (0x4c (nil) (nil) (nil) 0x77acee70
0x77c5040c 0x00002000 0x00000003 0x00000000 L"Program Files"
trace:file:NtQueryDirectoryFile => 80000006 (0)
fixme:dc:LockWindowUpdate (0x10024), partial stub!
fixme:dc:LockWindowUpdate ((nil)), partial stub!
myst at flash cdrom $ ls ~/.wine/drive_c/        

The name "PROG~FBU" is the same error name I saw with Gigasampler LE.
I'm sure it's some form of short name convention stuff, but why can't
Wine create what it needs?

I may test this against some, much earlier, other version to see what happens.

- Mark

More information about the wine-users mailing list