[Wine]raw parallel port access

BRC f4tq at yahoo.com
Tue Sep 21 14:22:45 CDT 2004

After quite a few days of perusing wine
doc/source/config/mailing lists, I have found very
scant references to accessing the raw parallel ports
using wine.  

I am running FC2 linux (up-to-date) and have confirmed
I can access the parallel port (dongle) presented to
VMWare running a Windows 2000 guest OS successfully
ie. access to /dev/parport0 works.

I can also run all the programs included with 
wine-20040914 as well as some tests I wrote with mingw
as well as those I compiled with VC++.  The latter
just cannot access the parallel port as VMWARE can
though it runs normally until it can't access the
dongle on LPT1.

I've tried running as root too to no avail.  What am I
missing?  If no answer is available, can someone at
least point to the relevant sources so I can puzzle it
out further:  I am determined.

Running with WINEDEBUG=+io yields no output yet
WINEDEBUG=+all spews the world as expected.

The relevant setup options I've played with are:

ln -s /dev/parport0 ~chris/.wine/dosdevices/lpt1

When I run as root, I symlink ~root/.wine ->
~chris/.wine for convenience.

The config ( I go back and forth on [ports] as I've
found different messages/doc professing both.

"lpt1" = "/dev/lp0"

;; key:  io-base of the emulated port
;; value : parport-device{,timeout}
;; timeout for auto closing an open device ( not yet
"378" = "/dev/parport0"
;;"278" = "/dev/parport1"
;;"3bc" = "/dev/parport2"

"FILE:" = "tmp.ps"
"LPT1:" = "|lpr"
"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred
-q -"
"LPT3:" = "/dev/lp3"

"read"  = "0x779,0x379,0x280-0x2a0"
"write" = "0x779,0x379,0x280-0x2a0"

#"read" = "0x378,0x379,0x37a,0x37c,0x77a"
#"write" = "0x378,0x379,0x37a,0x37c,0x77a"



Do you Yahoo!?
Take Yahoo! Mail with you! Get it on your mobile phone.

More information about the wine-users mailing list