[Wine]Cluster size not supported

Rein Klazes rklazes at xs4all.nl
Thu Sep 23 02:09:35 CDT 2004

On Tue, 21 Sep 2004 18:42:18 +0200, you wrote:

> On Tue, 21 Sep 2004 02:21:00 -0700, you wrote:
> > Rein,
> > 
> > You're gonna love this. I think I figured it out. It turns out that I 
> > had "lba32" enabled in my lilo.conf. I don't know much about windows, 
> > but I'm going to guess that windows98 doesn't play well with lba32.
> > 
> > Thanks for your help though. I hope this will help people who have the 
> > same problem in the future. I'm a little puzzled that more people don't 
> > have this problem since debian enables lba32 by default in the lilo.conf.
> You mean it worked after you disabled lba32 it worked? I'm installing
> wine now a system with Reiserfs and lba32 enabled, so we will see if
> that is right. 

Well I tried on a system with Reiserfs (version 3.6, kernel and
current cvs wine. It just works (installing dcom98). Lilo.conf contains

If you still want to continue, we will have to debug the
GetDiskFreeSpace function. 

There is a little test program at
http://www.xs4all.nl/~rklazes/temp/fds.exe.gz that reports the output of
this function. You use it as 

wine fds 'c:\' 

This is the code:

| #include <windows.h>
| int main(int argc, char* argv[])
| {
| 	int err;
| 	DWORD sectpclust,bytpersect,freeclust,totalclust;
| 	err = GetDiskFreeSpace( argv[1],&sectpclust,&bytpersect,&freeclust,&totalclust);
| 	printf("ret %d gle %d\nsectpclust %d bytpersect %d freeclust %d totalclust %d\n",
| 		err, GetLastError(), sectpclust,bytpersect,freeclust,totalclust);
| 	printf("sectpclust %x bytpersect %x freeclust %x totalclust %x\n",
| 		sectpclust,bytpersect,freeclust,totalclust);
| 	exit (0);
| }

Rein Klazes
rklazes at xs4all.nl

More information about the wine-users mailing list