[Wine] wine-0.9.2 compile problems under suse10-x86_64

Peter Beutner p.beutner at gmx.net
Fri Dec 9 03:55:06 CST 2005

Hartmut Wziontek schrieb:
> Dear Peter,
> many thanks for your reply,
>>> uid  -L/usr/X11R6/lib64  -lXext -lX11   -L../../libs/port -lwine_port
>>       ^^^^^^^^^^^^^^^^^^^^
>> You point it to the 64bit libraries.Which won't work with wine.
>>> /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld:
>>> ski
>>> pping incompatible /usr/X11R6/lib64/libXext.so when searching for -lXext
>> Thats why it is skipping the found libXext.so.And complains about not
>> finding a suitable one.
>> Im not sure who to blame for this(the configure script or your setup)
>> but you could try to
>> look for the string(/usr/X11R6/lib64), which should be somewhere in
>> the Makefiles and
>> change it to /usr/X11R6/lib32. Or add -L/usr/X11R6/lib32 as an extra
>> cflag.
> solved the problem with
>    ./configure --x-libraries=/usr/X11R6/lib
much better solution ;)

> (on my box /usr/X11R6/lib means /usr/X11R6/lib32)
>> Of course if you could find out why configure chooses the wrong
>> directory at all that
>> would be nice as well ;)
> sorry, wasn't able to figure this out, maybe it depends on the order
> in /etc/ld.so.conf if both types of lib are present? in my ld.so.conf
> the lib64 appears before lib.
hm ld.so.conf shouldn't matter afaik. IMO configure *should* figure out the 32bit libs to
link against. But honestly the whole autoconf/configure stuff is just black magic for me :/.

> regards - hartmut

More information about the wine-users mailing list